Bienvenido a Internet ■Volver al BBS■ Hilo completo ▼Bajar▼

[Deb] Ayuda Urgente (20 respuestas)

1 : root@bienvenidoainternet.org:~# : 10/10/19(jue)00:09:59 ID:xDgUiOLH0 rep del

Bueno, no es de vida o muerte, pero necesito rápido una respuesta.
Estoy en debian y un programa me pide Libnotify.so.4 , pero está disponible en rpm, txz, amd64, i386, i586, i686, x86_64 y ninguna de las arquitecturas es debian, sólo están

ALT Linux Sisyphus
CentOS 8
CentOS 7
Fedora 30
Fedora 29
Fedora Rawhide
FreeBSD 12
FreeBSD 11
Mageia 7
Mageia 6.1
Mageia Cauldron
OpenMandriva Lx 4.0
OpenMandriva Lx 3.0
OpenMandriva Cooker
openSUSE Leap 15.1
openSUSE Leap 15.0
openSUSE Tumbleweed
ROSA 2016.1
ROSA 2014.1

Cual puedo usar? hay algún reemplazo?

GRacias

11 : root@bienvenidoainternet.org:~# : 10/10/19(jue)00:50:27 ID:xDgUiOLH0 rep del

>>10
>pero si lo bajaste de aquí, ahí puedes ver un link que dice "Linux 64 Bit":
>
Estaba seguro que instalé un debian de 32... en efecto, está el instalador para 64, voy a cambiarlo, pero ya es hora de dormir, ahí te cuento mañana.
Muchas gracias :D

12 : root@bienvenidoainternet.org:~# : 10/10/19(jue)00:59:59 ID:63lqjh5Ta! rep del

Un poco offtopic, pero...

¿Es verdad que esto del """"infierno"""" de librerías no pasa en los *BSD? No es primera vez que veo esto en Linux, aunque casi siempre es por lo mismo: hacen un .deb o un ejecutable con versiones raras y justo no está, o justo tienes la versión nueva y necesitas la anterior que te da conflicos...

Pero es arreglable.

Suerte con eso, baisa.

13 : root@bienvenidoainternet.org:~# : 10/10/19(jue)01:21:44 ID:VQCxBOis0 rep del

>>11
Definitivamente suena como si tuvieras un sistema 64-bit, para asegurarte ejecuta:

uname -m

>>12
Debería pasar con todos los sistemas operativos que usan bibliotecas dinámicas, eso incluye los BSDs. Esto ocurre porque cuando compilas un programa, lo compilas sobre una versión específica de bibliotecas. Por darte un ejemplo, instalas un programa que está compilado sobre libpng1.6, al instalar el programa normalmente por seguridad te pedirá instalar libpng1.6 y no te dejará instalarlo si tienes, por ejemplo libpng1.5 o 1.4. Puedes forzar a instalarlo, puede que funcione, pero muy probable que el programa se caiga con algún error críptico al intentar partir.

En el caso de Windows esto es raro porque normalmente los instaladores de los programas instalan la versión de la biblioteca que necesitan. El problema de esto es que terminas con un montón de bibliotecas de distintas versiones en tu sistema, muchas veces duplicadas y desordenadas en una montonera de carpetas. La otra solución es compilar estáticamente (es decir, que los programas traigan "incorporadas" todas las bibliotecas dentro del programa), lo bueno es que te ahorras todo este dolor de cabeza, lo malo es que el programa pesa más. Rust obliga a compilar estáticamente.

Pero igual el problema de >>1 no era ese, no era que la biblioteca era de otra versión, si no que el programa era de otra arquitectura distinta a la de su sistema (32-bit). Como el programa es de 32-bit intentaba buscar libnotify de 32-bit, pero como su sistema es de 64-bit sólo estaba libnotify de 64-bit, entonces decía que no estaba. O esa impresión me dio, puede que me equivoque, ahí veremos.

14 : root@bienvenidoainternet.org:~# : 10/10/19(jue)13:50:31 ID:ykgrGbn7a rep del

Me gusta ese hosting de vps que no tenga la Basura de .deb, ¿me podrías dexir el nombre? Tengo interés en conocer el servicio.

15 : root@bienvenidoainternet.org:~# : 10/10/19(jue)15:34:28 ID:ViUA4vog0 rep del

>>1
Tienes que agregar el soporte de arquitectura i386 en dpkg e instalar los paquetes con el sufijo :i386 para que te instale los de 32-bit.

16 : root@bienvenidoainternet.org:~# : 10/10/19(jue)15:35:43 ID:ViUA4vog0 rep del

>>12
Desde el lunes sólo Windows deja tener versiones x86 y x64 en la misma instalación.
Digo lunes porque salió el OS X Catalina que liquidó el soporte de 32 bits.

17 : root@bienvenidoainternet.org:~# : 10/10/19(jue)15:58:33 ID:ViUA4vog0 rep del

>>14
>vps
Puedes meterle prácticamente lo que sea en esos servidores.

18 : root@bienvenidoainternet.org:~# : 10/10/19(jue)16:01:20 ID:ViUA4vog0 rep del

>>13
>terminas con un montón de bibliotecas de distintas versiones en tu sistema, muchas veces duplicadas y desordenadas en una montonera de carpetas
lo cual es verdad a medias porque las bibliotecas que no sean de MS quedan en el directorio de la aplicación y se van al desinstalar.
Diferente es el caso del WinSxS que se quedan en el SO y no se van hasta que saques todas las apps que dependan de esa versión.

19 : root@bienvenidoainternet.org:~# : 10/10/19(jue)21:00:58 ID:F/FSotZh0 rep del

Luego de desinstalar , descargar y reinstalar el archivo para 64-bits, obtuve

GoPanda2 Updater

Checking for updates...

Checking for binary update...

checkNewerBin done!

Checking if there is a new version of GoPanda2...

Checking if translation updates are needed...

ahora me estoy loggeando al server :D

Muchas Gracias a >>7-san por sugerir
>Prueba ejecutar "file GoPanda2" para saber si es 32 o 64 bit, y "ldd GoPanda2" para saber sus dependencias.
Herramientas necesarias para la solución del problema.

Gracias BaI por salvarme otra vez, lurkeo todos los días para algún día ser tan útil como tú :D

20 : root@bienvenidoainternet.org:~# : 13/10/19(dom)22:30:36 ID:TJouQ6RA0 rep del

De nada baisano
10 KB

Ver nuevos posts

Nombre:  E-mail: 

weabot.py ver 0.8.8 Bienvenido a Internet BBS/IB